This topic contains 11 replies, has 2 voices, and was last updated by  ChrisBrown 3 weeks, 2 days ago.

  • Author
    Posts
  • Participant
    ChrisBrown
    Newbie
    Member since: 26.09.2018
    Number of posts: 7

    Good Afternoon,

    My orginization is in the process of upgrading our On Premise ESignLive solution from 6.2 to 6.5. As part of this upgrade we are attempting to make some documents WCAG 2.0 AA compliant.

    From reading documentation on this sight, from the ESignLive platform perspectve, i should simple be able to add .WithAda() to the settings using the SDK. However when i do that i get an error.

    {“code”:400,”message”:”Documents uploaded to accessible transactions must be accessibility enabled.”,”messageKey”:”error.validation.ada.notTaggedDocument”,”name”:”Validation Error”}

    However, from looking at your instruction page for this, i should only be seeing that error when the document itself is not tagged. My process is just creating the initial package which this page says is ok.

    https://docs.esignlive.com/content/c_integrator_s_guide/rest_api/packages.htm#Create5

    When using the SDK, this is the code i am using. just removing .WithAda() will allow the process to work again.

    var package = PackageBuilder
    .NewPackageNamed(productName)
    .WithSigner(SignerBuilder.NewSignerWithEmail(primary.Email)
    .WithFirstName(primary.FirstName)
    .WithLastName(primary.LastName)
    .WithCustomId(primary.SignerId)
    )
    .WithSettings(DocumentPackageSettingsBuilder.NewDocumentPackageSettings()
    .WithAda()
    .HideOwnerInPersonDropDown()
    .DisableFirstAffidavit()
    .DisableSecondAffidavit()
    .WithHandOverLinkHref(returnUrl)
    .WithHandOverLinkText(“Exit”)
    .WithDialogOnComplete()
    .WithoutOptOut()
    .WithoutDocumentToolbarDownloadButton()
    .WithoutLanguageDropDown()
    .WithDecline()
    .WithoutCaptureText()
    .WithoutWatermark()
    .WithCeremonyLayoutSettings(CeremonyLayoutSettingsBuilder.NewCeremonyLayoutSettings()
    .WithoutBreadCrumbs()
    .WithoutNavigator()
    .WithoutSessionBar()
    .WithoutProgressBar()
    .WithoutGlobalConfirmButton()
    .WithoutGlobalDownloadButton()
    .WithoutGlobalNavigation()
    .WithLogoImageSource(logoSource)
    )
    )
    .Build();

    var packageId = _eslClient.CreatePackage(package);
    return packageId;

    Now i seem to be able to use the rest service directly and get some traction in creating a package. I am running into completely different problems with that and as such i would prefer to keep using the SDK if at all possible

    Keymaster
    Duo_Liang
    Guru
    Member since: 14.06.2018
    Number of posts: 398

    Score

    0

    Good afternoon Chris,

    I believe on-permise version 6.5 equals to version 11.13 in SaaS environment. If the behavior is not consistent with it should be, as a workaround, can you first don’t set .WithAda() and after you uploaded your first document or before sending then you enable Ada? At the same time, you can contact our support team at sign.support@onespan.com to create a ticket for yourself on this issue. Then we can create an exactly same environment at our side and test and solve the issue for you.

    Hope this could help you!
    Duo


    Duo Liang
    OneSpan Junior Technical Evangelist
    Participant
    ChrisBrown
    Newbie
    Member since: 26.09.2018
    Number of posts: 7

    Score

    0

    I can certantly try your workaround, What SDK command can i use to Update the package settings to enable ADA at the points that you have indicated?

    I can also create a ticket for this, i was just hoping for a faster response as my last couple of times creating a ticket have had a week pass before receiving a response

    Keymaster
    Duo_Liang
    Guru
    Member since: 14.06.2018
    Number of posts: 398

    Score

    0

    Hi Chris,

    Sorry for my incorrect statement, I’ve tried in .Net SDK and received “The ADA flag cannot be updated once documents are uploaded” error, which means this workaround may not workable.
    So can you only create the empty transaction (with no documents) with REST method and after this, other processes are done by SDK? Do you encounter any error message when creating an empty package with REST?
    And no worries, you can send me the ticket number and I will follow up this for you.

    Duo


    Duo Liang
    OneSpan Junior Technical Evangelist
    • This reply was modified 3 weeks, 4 days ago by  Duo_Liang.
    Participant
    ChrisBrown
    Newbie
    Member since: 26.09.2018
    Number of posts: 7

    Score

    0

    I have created the ticket. it is Case# 00110986

    When using the REST service i simply do not get the error. but none of the other settings seem to apply. Such as I have set WithoutNavigator and WithoutDocumentToolbarDownloadButton but both of those still appear making me wonder if the ADA flag is being registered either.

    I am working currently with an unfortunate limitation in that I do not have a reader to verify that the ADA flag truely works yet. that is part of the reason why id prefer to use the SDK.

    Keymaster
    Duo_Liang
    Guru
    Member since: 14.06.2018
    Number of posts: 398

    Score

    0

    Hi Chris,

    I will follow up the ticket, and once there’s some reply I will come back to you.
    On the other hand, can you share the REST code you are using? Can you use a HTTP traffic monitor tool like Fiddler to get your request? You can grab your package object and print the settings to see whether these two are settled or you can use POSTMAN to grab your package metadata.

    Duo


    Duo Liang
    OneSpan Junior Technical Evangelist
    Participant
    ChrisBrown
    Newbie
    Member since: 26.09.2018
    Number of posts: 7

    Score

    0

    I was going to look more in depth at the differences I had between the two calls tomorrow. I do see a couple of obvious differences that i will address to see what happens. such as the sdk object name layout vs the rest call CeremonyLayoutSettings.

    I am still using the SDKs DocumentPackageSettingsBuilder.NewDocumentPackageSettings() to create the package settings even in the REST call and am just rapping it in an annonymous type that then gets serialized by NewtonSoft. Tomorrow ill probably try creating it by hand.

    I changed some of the data fields that have some information id prefer not to share but here is what i have captured

    Fiddler from using SDK

    {
    “autocomplete”:true,
    “data”:{“sdk”:”.NET v11.12″},
    “description”:””,
    “documents”:[],
    “emailMessage”:””,
    “messages”:[],
    “name”:”PackageName”,
    “roles”:[
    {
    “attachmentRequirements”:[],
    “id”:”customer”,
    “index”:0,
    “locked”:false,
    “name”:”customer”,
    “reassign”:false,
    “signers”:[
    {
    “auth”:
    {
    “challenges”:[],
    “scheme”:”NONE”
    },
    “email”:”fakeemail@fake.com”,
    “firstName”:”Han”,
    “id”:”customer”,
    “lastName”:”Solo”,
    “professionalIdentityFields”:[],
    “specialTypes”:[],
    “userCustomFields”:[]
    }],
    “specialTypes”:[]
    }],
    “settings”:
    {
    “ceremony”:
    {
    “declineButton”:true,
    “declineReasons”:[],
    “disableFirstInPersonAffidavit”:true,
    “disableSecondInPersonAffidavit”:true,
    “ada”:true,
    “documentToolbarOptions”:{“downloadButton”:false},
    “events”:{“complete”:{“dialog”:true}},
    “handOver”:
    {
    “href”:”https://www.google.com”,
    “text”:”Exit”,
    “title”:”https://www.google.com”
    },
    “hideCaptureText”:true,
    “hideLanguageDropdown”:true,
    “hidePackageOwnerInPerson”:true,
    “hideWatermark”:true,
    “layout”:
    {
    “header”:
    {
    “breadcrumbs”:false,
    “globalActions”:
    {
    “confirm”:false,
    “download”:false
    },
    “globalNavigation”:false,
    “sessionBar”:false,
    “titleBar”:{“progressBar”:false}
    },
    “navigator”:false
    },
    “optOutButton”:false,
    “optOutReasons”:[]
    }
    },
    “trashed”:false,
    “type”:”PACKAGE”,
    “visibility”:”ACCOUNT”
    }

    Fiddler from using Rest call

    {
    “settings”:
    {
    “ceremony”:
    {
    “ShowLanguageDropDown”:false,
    “EnableFirstAffidavit”:false,
    “EnableSecondAffidavit”:false,
    “ShowOwnerInPersonDropDown”:false,
    “EnableInPerson”:true,
    “EnableOptOut”:false,
    “DisableOptOutOther”:null,
    “EnableDecline”:true,
    “DisableDeclineOther”:null,
    “HideWatermark”:true,
    “HideCaptureText”:true,
    “Ada”:true,
    “DeclineReasons”:[],
    “OptOutReasons”:[],
    “MaxAuthAttempts”:null,
    “ShowDownloadButton”:false,
    “ShowDialogOnComplete”:true,
    “LinkText”:”Exit”,
    “LinkTooltip”:null,
    “LinkHref”:”https://www.google.com”,
    “CeremonyLayoutSettings”:
    {
    “IFrame”:null,
    “BreadCrumbs”:false,
    “SessionBar”:false,
    “GlobalNavigation”:false,
    “ShowGlobalSaveAsLayoutButton”:null,
    “ShowGlobalDownloadButton”:false,
    “ShowGlobalConfirmButton”:false,
    “ProgressBar”:false,
    “ShowTitle”:null,
    “Navigator”:false,
    “LogoImageSource”:null,
    “LogoImageLink”:null
    }
    }
    }
    ,”type”:”PACKAGE”,
    “language”:”en”,
    “name”:”PackageName”,
    “roles”:[
    {
    “type”:”SIGNER”,
    “id”:”customer”,
    “name”:”customer”,
    “signers”:[
    {
    “id”:”customer”,
    “firstName”:”Han”,
    “lastName”:”Solo”,
    “email”:”FakeEmail@Fake.com”
    }]
    }]
    }

    Keymaster
    Duo_Liang
    Guru
    Member since: 14.06.2018
    Number of posts: 398

    Score

    0

    Hi Chris,

    Just a quick question, do you use a customized default consent document or you have it disabled? Because when you create a package without document, the default consent document will be added to the package. So can you please have a check and let’s see whether this makes the error.

    Duo


    Duo Liang
    OneSpan Junior Technical Evangelist
    Participant
    ChrisBrown
    Newbie
    Member since: 26.09.2018
    Number of posts: 7

    Score

    0

    That is an interesting question. One of the other things i have been battling with the upgrade to 6.5 is the default consent document.

    In this project, we want it disabled. I was not able to find any settings that disabled it in BackOffice specifically but i did find that if I created an account level document and left it null in 6.2 that would prevent it from showing up.

    In the upgrade to 6.5, that is no longer the case and uses the default consent document that is the backoffice wide version despite me having overridden it.

    This default document is NOT ada compliant

    I had searched through these forums for a solution for disabling of the Default Consent Document and found a post where the recomendation was to delete the document prior to calling Send. That would be after i make this initial call.

    I will see if I can get someone to make an ADA compliant version of the default consent document to load into this account, even though we dont want to use it. at least that may be a good test case to see if that is the specific problem.

    Participant
    ChrisBrown
    Newbie
    Member since: 26.09.2018
    Number of posts: 7

    Score

    0

    Good Morning. I did a test using a tagged document in the default consent and was getting the same error.

    Oddly enough, when i returned the default consent document back to a null value, it once again removed the document just like it did in 6.2 without me needing to reintroduce the code to delete, so im going to write that off as an upgrage peculiarity.

    Keymaster
    Duo_Liang
    Guru
    Member since: 14.06.2018
    Number of posts: 398

    Score

    0

    Hi Chris,

    Good morning. In our Saas environment, our support team also leaves default consent a null value to remove it from the account level, so I guess what you did originally is correct.
    And have you tried creating an initial package without default consent document? Did it still return that error?

    Duo


    Duo Liang
    OneSpan Junior Technical Evangelist
    Participant
    ChrisBrown
    Newbie
    Member since: 26.09.2018
    Number of posts: 7

    Score

    0

    I tried again, just for the sake of paranoia. Yes I am still getting the error

    {“code”:400,”message”:”Documents uploaded to accessible transactions must be accessibility enabled.”,”messageKey”:”error.validation.ada.notTaggedDocument”,”name”:”Validation Error”}

You must be logged in to reply to this topic.